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Geodesy...

“... a branch of applied mathematics that determines the exact positions of points on large portions of the Earth's surface; 
the shape and size of the Earth; and the variations of terrestrial gravity and magnetism.” 

The science of geodesy has been available for hundreds of years, yet many surveyors do not utilize this powerful method 
for processing their data. Why? Because without the power of computers, the mathematics of geodesy are rigorous—much 
more so than the number-crunching required for projected coordinate systems. In the past, geodesy was viewed as a 
method to use only for large scale, high-precision surveys. 

However, geodesy can—and could—be used for any size project. Whether your survey spans several thousand kilometers 
or only 100 meters, geodesy is the best mathematical model for processing field measurements. 

The reasons are many:

•  The geodetic coordinate system is worldwide; there are no boundaries. Stations established from independent 
surveys are directly related to each other.

•  The mathematical model is geometrically exact with no systematic distortions.

•  Field measurements are used as measured. No reductions are applied, thus the most accurate coordinates can 
be determined.

•  No special measurement collection procedures are required.

•  Resulting coordinates are latitude, longitude and height, ECEF XYZ, State Plane NEE, UTM (TM) NEE and/or 
Local Horizon Plane NEE.

•  The elevation (orthometric height) for each station can be determined using either GPS or terrestrial 
observations.

•  A variety of field observation types can be combined into each project. Stations can be separated by less than a  
centimeter or up to several hundred kilometers.

To use the geodetic model, all you need is COLUMBUS, one or more control stations, and your measured field data. 

COLUMBUS does the rest! Simply load your field data, select your stations and observations, and then compute!
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Installation

COLUMBUS can be installed and operated on any PC running Microsoft Windows XP or newer operating system.

To install COLUMBUS Network Adjustment Software, insert the CD into your CD ROM drive. From the Start menu, select 
Run, type d:\setup.exe and click the OK button. Follow the instructions of the installation program.

If you have downloaded COLUMBUS from our Web site (www.bestfit.com), simply run the coldemo38.exe executable to 
begin the installation process.

We have provided 16 ASCII (Text) project files, which demonstrate different network adjustment and/or traversing 
scenarios. Each project file contains the instructions (within the comment section of the file) on how to perform an 
adjustment or traverse. For most project files, we have also included a report (*_RPT.TXT) file. Before exploring each 
demo file, you may find it helpful to briefly review the corresponding report file.

Below is a description of each file:

BEAR2D.TXT This project file contains a small 2D geodetic network (one half of a PLSS section from a 
township) consisting of recorded mean bearing and horizontal distance survey data.

BIGBASIN.TXT This project file contains a network consisting of 17 stations (four of which are 3D control 
stations) and 126 GPS and terrestrial observations. This sample is also used for demonstrating 
the Solve All Combinations logic described at the end of this document.

BIGBASIN_NET.TXT This project file has the same stations and observations as BIGBASIN.TXT. It also contains all 
the applicable Option Settings and fixed station settings. Review the BIGBASIN.RPT file for 
this project.

GEO.TXT This project file contains a small 3D geodetic network consisting of geodetic stations and 
terrestrial observations. This project contains the same data as the GEO_TRAV.TXT project.

GEO_TRAV.TXT This project file demonstrates 2D and 3D geodetic traversing. This project contains the same 
data as the GEO.TXT project.

GPSONLY.TXT This project file contains a small 3D geodetic network consisting of geodetic stations and GPS 
observations.

MIXED.TXT This project file contains a small 3D geodetic network consisting of geodetic stations, and a mix 
of GPS and terrestrial observations.

NEE.TXT This project file contains a small 3D Local Horizon Plane NEE network, which can be adjusted 
using the local NEE adjustment engine.

NEE_TRAV.TXT This project file demonstrates 2D and 3D Local Horizon Plane NEE traversing. It does not 
contain the same data as NEE.TXT.

STATEPLANE.TXT This project file contains a small 3D State Plane network consisting of State Plane stations and 
terrestrial observations. This project contains the same data as the STATEPLANE_TRAV.TXT 
project.

STATEPLANE_TRAV.TXTThis project file demonstrates 2D and 3D State Plane traversing. This project contains the same 
data as the STATEPLANE.TXT project.
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TERRONLY.TXT This project file contains a small 3D geodetic network consisting of geodetic stations and 
terrestrial observations. This network can also be adjusted in 2D at an average project height.

TRIGLEVEL.TXT This project file contains a sample data set (with instructions) for processing Trig Levelling data. 
There is no report file for this project.

UTM.TXT This project file contains a small 3D UTM network consisting of UTM stations and terrestrial 
observations. This project contains the same data as the UTM_TRAV.TXT project.

UTM_TRAV.TXT This project file demonstrates 2D and 3D UTM traversing. This project contains the same data 
as the UTM.TXT project.

VERTICAL.TXT This project file contains a small 1D vertical network consisting of height stations and height 
difference (levelling) observations.

Before loading each sample project file into COLUMBUS, take a moment to examine its contents for instructions 
on how to process each network (or traverse) contained in the file.
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DEMO LIMITATIONS
The demonstration version of COLUMBUS has been configured to handle only a fraction of your computer’s capacity. The 
maximum number of stations allowable for the demo version is 12 (BIGBASIN.TXT and BIGBASIN_NET.TXT can still 
be loaded even though they have 17 stations). There is no practical limit to the number of observations that can be loaded 
in the demonstration version of COLUMBUS.

The full version of COLUMBUS has been used to adjust simulated networks with up to 45,000 stations and containing 
hundreds of thousands of observations.
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Online Tips For Using COLUMBUS

We have developed online resources to help you use COLUMBUS more effectively. The first is our Quick Tips section, 
which can be found by clicking on the Quick Tips link at www.bestfit.com The second resource is our Real-World 
Applications link, which explains selected topics in greater detail. The link to this topic can also be found on our home page.

We would like to strongly encourage you to use these resources as you learn more about COLUMBUS. Both sections are 
continually being enhanced with new topics.
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Quick Start - Creating A Project Interactively

To use the data entry grids to create a project from scratch, do the following for optimal efficiency.

1. Create a new project (File - New) and select the datum to be active in the OPTIONS - DATUMS dialog.

2. Setup the view. If this will be a State Plane coordinate based project, set the view to State Plane (2D or 3D). For a
Geodetic coordinate based project, set the view to Geodetic (2D or 3D), etc.. This step allows COLUMBUS to
automatically generate coordinate stations when you enter observations (below). 

3. If this is a State Plane, UTM (3TM, TM), or Custom Projection based project, select (or set up) the zone in the
applicable OPTIONS dialogs. If this is a Local NEE project, set up the approximate latitude for the project in the
OPTIONS - GLOBAL SETTINGS dialog.

4. Enter the applicable DATA - OBSERVATIONS tabbed dialog (Horizontal Angle Set, Direction Set, Azimuth Set, etc.)
and begin entering station names (AT, TO, BS) and the observation data. Be sure to be consistent with your station
names when referring to the same point on the ground. A station name of TOP is not the same as Top (these are
two different station names). COLUMBUS station and datum names are case sensitive.

5. If an observation was not measured (for example a chord distance), leave the observation field blank.

6. After entering several observations, select the Keep and Exit button. Stations referenced by the observations will be
created automatically. If the active view was set to State Plane (3D), then State Plane stations will be created. 

7. Edit any station for which you have known coordinates (usually just your control stations).

8. Save your project using the File - Save command to prevent accidental loss of changes. 

For additional information on using each data entry grid, please see Chapter 4 of the user manual. Each chapter can be 
downloaded individually or all together (in a zipped file) at: www.bestfit.com/docum.shtml
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How COLUMBUS Is Organized

COLUMBUS is organized around nine functional areas. Following is a brief description of each function:

FILE
The File menu provides file management tools for creating a new project; opening a new project (Figure 1 below); 
appending data to a existing loaded project; saving the current project; extracting data from third-party data files; 
and print/print preview of the current project and network adjustment/pre-analysis results.

Figure 1: MIXED.TXT Network View

VIEW
The View menu allows you to change the view context of the active project. For example, you can view a network 
in one of the following contexts: 1D Vertical, 2D Geodetic, 3D Geodetic, Cartesian XYZ, State Plane (2D), State 
Plane (3D), UTM (2D), UTM (3D), Local NE (2D), or Local NEE (3D). The available context options are dependent 
on the type of data in the project.
The majority of computations within COLUMBUS are context-dependent on the active project view.
From this menu, you can also setup or clear a route (sequence of stations), resize network entities (station names, 
station symbols, and error ellipses), zoom in or out on a defined area of the active project view, display/hide 
stations, the toolbar, and the status bar.
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DATA
The Data menu facilitates the entry and editing of data (stations, observations and datums) for the current project. 
A complete project can be entered here using our intuitive spreadsheet style grids. You can also create your 
project within an ASCII (Text) input file (similar to the examples described in this document).

From this menu, observations can also be temporarily disabled to exclude them from Network Adjustment/Pre-
Analysis and COGO processing.

NETWORK
COLUMBUS adjusts networks using the method of Indirect Observations (also known as the Unified Approach). 
This is the most common method in use today. Much of the adjustment theory built into COLUMBUS has been 
adopted from papers published by the National Geodetic Survey (NGS - U.S.A). Overall, the geodetic theory used 
within COLUMBUS has been taken and combined from several leading independent sources. We provide a 
complete list of references to these sources within the Appendix of our user manual and on our Web site 
(www.bestfit.com) from the Theoretical Foundation link.
The Network menu provides all the tools required to adjust one-, two- and three-dimensional vertical, geodetic, 
ECEF XYZ, State Plane, UTM (TM), Custom Projections and Local Horizon networks. The type of network 
adjustment to be performed is dependent on the current project view. For example, if the current view is 2D 
geodetic, then a 2D geodetic adjustment can be performed. Likewise, to perform a 3D geodetic adjustment, the 3D 
geodetic view must be active.
You can also perform network pre-analysis on 2D and 3D surveys from the Network menu. Network pre-analysis 
(commonly called design) enables you to design your survey before going into the field. Simply provide 
COLUMBUS with the approximate locations of your planned survey points (scaling from a map is usually 
adequate), the observation types you expect to measure, and the expected precision for each observation, 
expressed as a standard deviation or covariance matrix (for GPS baselines). COLUMBUS can then compute the 
statistical level of precision you can expect to achieve, based on your design. If your design is not adequate for the 
future adjusted precision desired, make changes and analyze your design again. Network pre-analysis can save 
valuable time in the field by allowing you to optimize your network geometry and the types and frequency of the 
observations that must be measured. Please visit our Web site for more help on setting up a Network Adjustment 
and Design under the applicable Quick Tips topic.

RESULTS
The Results menu allows you to view the network adjustment or design results. Several views can be displayed 
simultaneously, including an adjusted view of the network - complete with resizable error ellipses and height error 
bars. For each view, you can use Print and Print Preview to further examine each report as hard copy or on-
screen. The results from each view can also be written to a report file (see the Report toolbar icon) and to a 
Microsoft Excel CSV file comma-delimited file (with just the data and no formatting). Network adjustment report 
generation can also be automated by selecting the desired reports in the Options - Network Options - Report 
Settings dialog.

TOOLS
The Tools menu provides powerful tools for transforming geodetic coordinates to several other coordinate 
systems, performing COGO traverse and inverse computations, and much more. Tools menu options can be used 
alone or in combination with the Network menu options.
Most of the options within the Tools module are context-sensitive to the Main Project Graphical View or Network 
Adjustment Graphical View. Look at the dialog title for each Tool option to determine its context. For example, if 
the Network Adjustment Graphical View is active, all applicable Tool options are based on the adjusted 
coordinates. If the Main Project Graphical View is active, all applicable Tool options are based on the data for each 
station, i.e., data that are part of the project.
The Datum Transformation tool is a very most powerful features, giving you the ability to transform geodetic 
coordinates based on one datum (NAD 83, WGS 84, etc.), to geodetic coordinates based on a second datum (NAD 
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27, Bessel, etc.). Also, you can transform geodetic coordinates to/from ECEF Cartesian, State Plane, UTM and 
Local NEU. Resulting coordinates can quickly be exported to other software systems.

The COGO (coordinate geometry) option provides tools for vertical, geodetic, ECEF XYZ, State Plane, UTM, and 
Local Horizon coordinate geometry traverse and inverse computations. You can compute loop closures or open-
ended traverses. 

The remaining Tools menu options allow you to compute areas; scale projected coordinates; model geoidal 
heights and deflections of the vertical; create NGS NADCON input files; and export data to a DXF or user-defined 
data file.

OPTIONS
The Options menu allows you to change the run-time parameters within COLUMBUS. Usually the defaults will be 
adequate, but they may require changing, depending on your specific processing requirements. You can also 
manage mutliple sets of Options Settings (customized to each type of project) within the Options Library Manager.

WINDOW
The Window menu allows you to arrange your work area, following the standard Microsoft Windows conventions. 
You can Cascade or Tile views. Using the Arrange Icons command, you can arrange your iconified project icon. 

HELP
The Help menu provides access to the Index to COLUMBUS’ extensive Help system. Information is also provided 
about using Help and about your current version of COLUMBUS.

NOTE ABOUT REPORT VIEWS
Most numerical results are now presented in list report form. These reports contain multiple resizable columns that 
can be customized by you to only show the columns you want. Changes made to any column alignments are 
automatically saved for future COLUMBUS sessions.

Each column in a list report can be sorted (ascending and descending) by clicking on the column header. The order 
of the printable report will match the current sorted column on screen.

Each and every report can also be written to a comma-delimited Microsoft Excel CSV file format. These files 
contain the actual results without all the normal formatting. In this form, your data can be easily loaded into excel 
for further manipulation. Because the excel CSV file is a simple comma-delimited file, you can also import 
these files directly into other software packages for further processing, drawing, etc.

To activate the generation of CSV files, select the Report Headings command from the Options menu and enable 
the Create comma-delimited text report… check box. When you send the results of any list report to a report file, 
a corresponding excel CSV file will also be created with the extension *.csv (using the same report file name and in 
the same folder.)
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Project Data Model

COLUMBUS is a completely integrated system. From within one program, several types of computations can be 
performed. Users of COLUMBUS find that many of the tasks that previously required separate programs can be solved 
within the COLUMBUS environment. Unlike other network adjustment programs, COLUMBUS opens all station and 
observation data into a project for manipulation and computation. The data are available until you close the project.

One of the most powerful features of COLUMBUS is its built-in data sharing. Once data have been entered within the 
applicable Data module or opened within the File module, they are available for computations in any of the applicable 
numerical modules. If a network has been recently opened, the data can be used to quickly perform inverses or loop 
closures. Station data can be easily transformed from one coordinate system to another.

Figure 2: COLUMBUS Data Hierarchy

Project usage in COLUMBUS is similar to the process of making changes to a file using a text editor. Once data have been 
opened into a project, they can be modified, appended or deleted without affecting the original data on disk. Within 
COLUMBUS, data in a project are saved to disk only when you select from the File menu either the Save or Save As 
options, or select from the Network menu the Save Network option. Like having several versions of a project with minor 
modifications in each, you can have several versions of the same data in separate disk files. This is accomplished by 
continually saving data in your project to separate disk files (or the same file if preferred) following each alteration.

Not only can different modules gain access to your data, each numerical module has the ability to Keep new data into the 
active project from current computations. For example, you perform a geodetic network adjustment, but need to report the 
adjusted geodetic positions in State Plane (projected) form. Once the adjustment is completed, you can Keep the adjusted 

COLUMBUS 
Document

Datum Datum Datum

Station

Obs

Obs

Obs

Station

Obs

Obs

Obs

Station

Obs

Obs

Obs



Copyright 1996-2009 Best-Fit Computing, Inc. Demo Doc-13

geodetic coordinates into the active project by selecting Keep from the Results menu or by using the toolbar button, giving 
other modules access to the adjusted coordinates. You can then move to the Tools menu and select State Plane <--> 
Geodetic to transform the adjusted geodetic coordinates to State Plane coordinates. 

Note: Another way to accomplish this is to perform the network adjustment, then open the Adjusted Network view. From 
the Tools menu, select the Geodetic to State Plane transformation. Since the Adjusted Network view is active, the 
transformation computations will be based on the adjusted geodetic coordinates.

The advantage of this system is the elimination of re-entering computed coordinates. This minimizes the possibility of data 
entry errors and saves valuable time. This feature also removes the needless construction of multiple intermediate data 
files that tend to clutter your disk directories. With COLUMBUS, each project can be stored in one data file or across 
several data files.
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ASCII (Text) Files

COLUMBUS supports two file formats for data files. Each format can be used independently or combined together in the 
same file. 

•  The expanded format usually spans more than one line of the text file for each input record. This format is sup-
ported for backward compatibility, but it is no longer generated by the File - Save commands.

•  The compact format allows you to define an entire input record on one line of text. Data fields are separated by 
the semicolon character ( ; ). All demo data files (files with *.TXT extension) are in this format.

COLUMBUS also supports the concept of an include file list. From within each file, you can include other files. These 
included files are automatically loaded by COLUMBUS. If your project is made up of dozens of input files, you can create 
one master input file (for example, master.txt), which then includes all the project files. See Appendix A for details on using 
the $INCLUDE_FILE keyword.

You can use the online data entry grids to create projects interactively or you can create a COLUMBUS input file directly 
(using your favorite text editor). You can also combine both methods - enter data online, then save to a file, then make 
additional file edits, then load the file and make additional interactive edits.

The ASCII (Text) file has four main types of data: Datums, Units, Stations and Observations. Each type can be repeated in 
the file as often as you like. For a complete listing of available ASCII (Text) keywords, please see Appendix A of the 
COLUMBUS user manual (www.bestfit.com/docum.shtml).

Stations can either be explicitly or implicitly defined within the file. To explicitly define each station you must provide some 
coordinate values. To implicitly define each station, simply add this record type to the top of the file:

$STATION_TYPE_FOR_OBS
3D_GEO  (or 1D_VERT, 2D_GEO, 3D_ECEF, 2D_STATE, 3D_STATE, 2D_UTM, 3D_UTM, 2D_NE, 2D_NEU) 

When the file is opened, the applicable station type will be automatically created (with coordinates of zero) when an 
observation is read, which reference the station.

When creating the ASCII (Text) file, all types of data are optional. If the Datum data is not included, the opened data is 
linked to the active datum. If the Units data is not defined, all linear values are assumed to be in the active linear units. All 
applicable angular values are assumed to be in the active angular units.
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Data Editing 

The DATA module allows you to add, modify or delete station, observation, and datum data currently in the project through
an assortment of intuitive spreadsheet like grids. A complete project can be entered using these grids or by creating
your project within an ASCII (Text) input file.

You can also disable individual observations. Observations that are disabled will not be available for use in Network
Adjustments, Network Pre-Analysis, or COGO Traverse computations.

There are three basic data components in COLUMBUS:

STATIONS locations on the ground
OBSERVATIONS measurements between stations
DATUMS ellipsoidal parameters

When entering or editing data, it is very important to work with the units defined in the OPTIONS - UNITS dialog. If the
linear units are set to meters, all linear quantities must be entered in meters, except the major axis for a datum, which must
always be entered in meters. Internally, COLUMBUS converts all linear quantities to meters and angular measurements to
radians. If the selected linear units are U.S. Survey Feet, COLUMBUS converts all applicable linear data from U.S. Survey
Feet to meters before storing them internally. Upon output, the results are then reported back in U.S. Survey Feet.

Likewise, angular measurements must be made in the active angular units. COLUMBUS currently supports degrees and
grad (or gon) units. See the OPTIONS chapter of this manual for more information on the supported angular formats.

Keeping track of the input units is easy when using the spreadsheet grids. When you select a cell to edit, the units of entry
are displayed in the upper left corner of the current Tabbed Page.

If you enter a value that is out of range (in a cell), then move to another cell, an error message will be displayed in the upper
left corner of the current Tabbed Page. This message will indicate the proper numeric (or text) range for the cell you just
left. The cell will also be restored to its orginal value (before the bad data was entered).
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Using The Data Grids 

The data grids allow you to quickly enter or modify project data. Each grid serves a specific purpose, but they are all used
in the same way (mouse + keystrokes or keystrokes alone). These grids utilize many of the same keystroke combinations
found in popular spreadsheet software.

Keep and Exit:

After making changes in any grid, select the Keep and Exit button to accept the changes into the project.  Data are not
saved to disk until you invoke the File - Save or File - Save As command. 

Cancel:

To cancel changes at any time, select the Cancel button. If any data changes have been made in the grid, you will be
prompted with a message asking you if you really want to discard your changes.

When you select Cancel, COLUMBUS looks for any change in the grid. If changes exist (e.g., you added a new empty
row), a scan is made to see if those changes would alter the project. If not (as in this example), no user prompt is made. 

Suppose you opened an observation grid and changed a slope distance from 1300.25m to 1300.255m. Before closing the
grid, you then changed that distance back to1300.25m. If you now select Cancel, no user prompt will be made, since the
project data has not changed.

Add Row:

New data are always added to the bottom of the grid. You can add new rows by invoking the Add button or by repeatedly
pressing the ENTER key to move to the last row and then add additional rows.

The user entered row order is not maintained in COLUMBUS. When the Station, Observation or Datum grids are activated,
the data is always ordered alphabetically by; the AT station name (Stations), the AT, TO, BS station names (Observations),
and the Datum name (Datums).

Empty rows are ignored and removed as soon as you move to another Tab or close the dialogs.

Delete Row:

To delete a row of data from the project, clear out all fields on that row. When Keep and Exit is selected, the data that was
on that row will be removed from the project. When you delete a station (using this method) all observations connected to
that station will also be deleted (including horizontal angles that backsight into the station).

Rename Station or Datum:

To rename a station, open the Station Tabbed dialogs and select any one of the Station Tabs (Geodetic, State Plane, etc).
Change the desired station name (modify its text). The new name must not match any other station name currently in the
grid or you will get an error message. When the Keep and Exit button is selected, the name will be changed in the project.
All observations linked to that name will also be automatically updated.

To rename a datum, follow the same process.

Adding Similar Rows Of Data:

When adding several rows of data (for which many fields are identical) use copy/paste. First, add several blank rows to the
grid. Second, using your mouse or keystrokes, highlight the entire row of data you wish to replicate. Use Ctrl + C to copy
the row. Move to the beginning (first cell) of the first blank row and perform a paste Ctrl + V. Move to each additional blank
row and paste the data in the same way. Make specific edits to the fields that are different.
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When doing this operation within the Station or Datum grids, you will not want to add the station name (first cell in each row)
to the copy/paste operation. If you do, you will get a duplicate name message after each paste. Instead, copy the 2nd thru
n cells of each row (skipping cell 1 of each row.)

Column Widths:

You can change the width of any column. These changes are remembered by COLUMBUS.

Column Sorting:

You can perform column sorting by clicking on the desired column header. This will sort all rows based on the items in that 
column. Click on the column again to reverse the sort. When sorting columns that contain Real numbers, you can sort by 

the abolute value by first enabling the View - Sort By Absolute Value command.

Keystroke Naviagtion Summary

Below is a list of the most commonly used keysrtoke combinations. You may discover that exclusive use of the keyboard
(no mouse) is more efficient when entering large amounts of data.

Cell Modes:

Edit Mode When editing a cell

Entry Mode When on a cell, but not in edit mode

Navigation:

Ctrl + PgUp Next Tab page to the left

Ctrl + PgDn Next Tab page to the right

Ctrl + Tab Next Tab page to the right

Ctrl + Shift + Tab Next Tab page to the left

Tab Move to cell to right (Edit Mode)

Shift + Tab Move to cell to left (Edit Mode)

End Move to last cell in row (Entry Mode)

Home Move to first cell in row (Entry Mode)

Up Arrow Move up one cell

Down Arrow Move down one cell

Ctrl + Home Move to upper left corner of grid

Ctrl + End Move to lower right corner of grid
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Alt + K Keep changes and exit (Entry mode)

Select and Edit:

Alt + A Add a row (Entry mode)

Alt + Space Window menu

Ctrl + Space Select entire column

Shift + Space Select entire row

Ctrl + A Select all cells

Ctrl + Left Click Select multiple cells

Ctrl + C Copy content of selected cells

Ctrl + X Cut content of selected cells

Ctrl + V Paste clip board to cells

Ctrl + ‘ Copy contents of cell above (Entry mode)

Shift + Left Arrow Select multiple continuous cells to the left

Shift + Right Arrow Select multiple continuous cells to the right

Shift + Left Mouse Click Extend selection to selected cell

Shift + End Select current cell and all cells to its right

Shift + Home Select current cell and all cells to its left

Shift + PgUp Select current cell and all cells above

Shift + PgDn Select current cell and all cells below

Del Delete contents of selected cells (Entry mode)

Del Delete current character (Edit mode)

End Move to right side of cell (Edit mode)

Home Move to left side of cell (Edit mode)

Enter When in Edit mode, changes to Entry mode

Esc Exit grid and abandon changes (Entry mode)

Esc Abandon cell changes (Edit mode)

Bksp Delete cell contents (Entry mode)
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Bksp Delete character to left (Edit mode)
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Example - MIXED.TXT

The Network module is the most commonly used and sophisticated module within COLUMBUS. Although easy to use, the 
underlying software is very powerful for satisfying your “what-if” processing requirements. Networks can be constructed 
using up to 19 different observation types, including coordinate observations. You can freely mix GPS and terrestrial field 
data (within 3D networks) or use them separately. Each survey project can be solved as one large network or in user-
selectable subsets from within the integrated operating environment.

Below is the layout for this network example. There are six geodetic stations and 64 observations in this data set. Station 
MACK was fixed in three dimensions (latitude, longitude and ellipsoidal height).

Figure 3: MIXED.TXT Network Layout

For the complete view of this data file (in compact format), print or open the file MIXED.TXT from the COLUMBUS 
installation directory. The exclamation point (!) is used to comment out individual lines within the file. You can also use the 
two keywords $BEG_SKIP and $END_SKIP to comment large blocks of text or data within the input project file.

Since COLUMBUS computes approximate coordinates during adjustment, the accuracy of the entered coordinates for the 
floating stations is not critical. However, if COLUMBUS cannot compute approximate coordinates for a station, the entered 
coordinates should be estimated as closely as possible to their actual positions before attempting an adjustment (usually 
by scaling from a map). To adjust the MIXED.TXT network in 3D geodetic space, follow the steps outlined below:

1. Open the data file MIXED.TXT into a new project by selecting Open from the File menu.
2. From the View menu, select 3D Geodetic as the View context. Notice as you move the mouse over the network 

view, the status bar displays the latitude and longitude position of the mouse. To preview the coordinate data for 
any station, double-click the station symbol. To resize the station names or symbols, either click the Resize 
Entities toolbar button or select Resize Entities from the View menu. To preview observation sets, double-click 
the line between any two stations. 
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To compute a loop closure, use the right mouse button to define a traverse route by right-clicking on each station 
in the order of the route. Then select the applicable COGO Traverse option from the Tools menu or click the 
Compute 1D, 2D or 3D traverse toolbar button. You will then be presented with a list of all available observations. 
Select the observations desired, then invoke the OK button to compute the coordinates and closures for each 
station.
You can also set up (or edit) a traverse route from within the Setup COGO/Design Route dialog, accessed from 
the View menu.

3. From the Options menu, select Units and set the Linear Units to meters. 
4. From the Options menu, select Global Settings and set the 3D Geodetic Height to Ellipsoidal Height. The 

ellipsoidal height field will be used for the vertical control of Control Station MACK.

Figure 4: MIXED.TXT Adjusted View

5. Define the stations and observations that will be used in the current adjustment. Stations not selected to be in 
the network are not used in the adjustment. Stations fixed in 2D (latitude/longitude) and/or 1D (height) are 
considered to be floating and fixed, respectively, for a 3D network adjustment.

6. From the Network menu, select Network Stations. (Alternatively, click the Network Stations toolbar button.) 
Click the Select All button to select all the stations to be used in the current adjustment. Click the OK button. All 
multiple selection lists within COLUMBUS conform to Windows standard behavior. To select multiple items, hold 
the CTRL key down while simultaneously clicking on each list entry. You can also use the Shift key and mouse 
click sequence to select groups of items.

7. From the Network menu, select Fixed Stations. (Alternatively, click the Fixed Stations toolbar button.) Click on 
Station MACK to be fixed in 3D. Click the OK button. 

8. From the Network menu, select Observations. (Alternatively, click the Observations toolbar button.) Click the 
Select All button to select all the observations to be used in the current adjustment. Only observations linked to the 
selected network stations will be presented. The observations in this window are ordered alphabetically by the AT 
and TO station names. Click the OK button.

9. Begin the network adjustment by selecting the Adjustment command from the Network menu or by clicking the 
Start Adjustment (greenlight) toolbar button. 
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As the adjustment proceeds, COLUMBUS displays each processing step. After the adjustment is completed, 
review the adjustment summary dialog box using the scroll bar. From the Results menu, select Adjusted View to 
graphically review the adjusted network. 

•  To examine the error ellipses for any adjusted station or between stations, double-click within the applicable 
adjusted error ellipse.

•  To examine the adjusted coordinates for a station, double-click on the station symbol. 

•  To examine the adjusted observation between any two stations, double-click on the line connecting the station 
pair.

These views and several others can be selected from the Results menu. For each view, try the Print Preview 
command to see a “report style” look at the view (see Figure 5 below). Adjustment results can also be written to a 
report file by selecting the Report toolbar button.

If you prefer to see all adjustment results in the Network Processing Summary View, do the following: 
close the current adjustment, enter the OPTIONS - NETWORK OPTIONS - REPORT SETTINGS dialog and 
select the reports you want to automatically generate (some reports may not be applicable to the current view 
context, so they will not be generated), then restart the adjustment.

Figure 5: MIXED.TXT Print Preview of Adjusted Coordinates

The adjusted coordinates for each station are stored in a temporary area of the project. If you prefer, you can Keep 
the adjusted coordinates into the project to be used as fixed stations in subsequent adjustments by selecting Keep 
from the Results menu (the Keep command is only available when the adjusted coordinate view is the top most 
view active). The adjusted coordinates can also be transformed to other coordinate types by selecting 
Transformation from the Tools menu.
If at any time you need further information about the contents of a dialog box, simply click the Help button or press 
the F1 function key. COLUMBUS will display a Help screen summarizing the current display. For views, simply click 
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the ? toolbar button and move the mouse over the applicable view. Click on the view and context-sensitive Help 
will immediately be displayed.

10. To transform the adjusted geodetic coordinates to State Plane coordinates, click anywhere on the network adjusted 
view to make it the active view. This is the view that contains the graphical error ellipses and is shown in Figure 4 
above. You can examine the Adjusted State Plane Coordinates view.

11. From the Options menu, select Projection Zones, then select State Plane Zones. Next, select the ILLINOIS 
1202 TM Zone to be the active projection zone.

Figure 6: MIXED.TXT Adjusted State Plane (Projected) Coordinates

12. From the Tools menu, select Transformation, then select State Plane <--> Geodetic. Click the Compute button 
to bring up the list of your adjusted stations. Click the Select All button, then click the OK button. The adjusted 
State Plane coordinates will be displayed in the dialog box. Also displayed are the Mapping Angle and Scale Factor 
for each projected station.
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Network Adjustment Results

Below is an abbreviated example of the reports resulting from the 3D geodetic adjustment of MIXED.TXT. These reports 
can be generated automatically during adjustment, after the adjustment from within each result view, or by using the Print/
Print Preview command while examining each result view. To set up automatic report generation, from the Options menu, 
select Network Options, then select Report Script.

The first section shows a summary of the network adjustment settings and results.

3D GEODETIC NETWORK ADJUSTMENT SUMMARY
Datum                 NAD 83          1D Expansion Factor       1.95937
Linear  Units         Meters          2D Expansion Factor       2.44788
Angular Units         Degrees         3D Expansion Factor       2.79532
Field Observations    64              A Priori     Variance     1.00000
Coord Observations     0              A Posteriori Variance     0.72423
TOTAL OBSERVATIONS    64              Confidence Level         95.0
                                      Chi Square Test On Variance Factor
Num Stations           6                0.505 < 1.0 < 1.124  (Passes)
Fixed In 1D            0              Variance Factor Used      0.72423
Fixed In 2D            0
Fixed In 3D            1              No Check Observations     0
Float Coord Parms     15              Stan Res Rejections       1
                                        ( Tau Stat = 3.213 )
Direction Parms        0              Resid/SD Rejections       0
Scale Parms            0              Residual Rejections       0
Rotation Parms N       0              TOTAL OUTLIER OBS         1
Rotation Parms E       0
Rotation Parms Up      0              Iterations                3
TOTAL PARMS           15              Convergence Criteria      0.0010000
                                      Zenith Angle Refraction   0.00000
                                      Rotate Bearings           No
DEGREES OF FREEDOM    49              Use Full Covariance       Yes
A-POSTERIORI VARIANCE (and STAN DEV) FACTOR (by observation type)
Obs Type      Count     Sum of Squared      Redundancy     A-Post      A-Post
                      Weighted Residuals      (D.F.)      Variance    StanDev
Azimuth          2           1.518            1.139         1.332       1.154
Hor Ang         14           6.981            9.796         0.713       0.844
Zenith          13           3.068           11.584         0.265       0.515
Chord           13           7.685           10.788         0.712       0.844
Hgt Diff         4           0.176            0.589         0.299       0.547
GPS Obs         18          16.060           15.103         1.063       1.031
TOTALS          64          35.487           49.000         0.724       0.851
ADJUSTMENT COMPLETE = 0 Seconds

The next section lists the adjusted coordinates in compressed form. They can also be listed with the adjusted covariance 
matrix for each station. 

For this network, stations can be fixed in 1D (height), 2D (latitude and longitude) or 3D (latitude, longitude and height). To 
fix an individual latitude, set the latitude standard deviation to be very small (for example, 0.0000001 meters). Set the 
longitude standard deviation to be large (for example, 30.0 meters). From the Network menu, select Constrained 
Stations and then select the station to be constrained in 2D just prior to adjustment. This will, in effect, freeze the latitude, 
while allowing the longitude to move freely during adjustment. You can achieve this same result by using coordinate 
observations in COLUMBUS. 
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Adjusted Coordinates

  Station
  Latitude           SD       Longitude          SD        Ellip Hgt    SD

  5010
  N  39-29-59.99799  0.1107   W  89-49-59.99861  0.0968     1099.98242  0.0515

  MACK
3 N  40-00-00.00000  0.0000   W  90-20-00.00000  0.0000     1000.00000  0.0000

1 - 1D Fixed    2 - 2D Fixed    3 - 3D Fixed

The next section lists the adjusted observations. First, the three critical outlier value types are shown. An outlier constant 
can be set for each observation type. In this example, the Azimuth Residual rejection constant is 10.0 seconds, while the 
Chord Distance residual rejection constant is 1.0 meter. If any azimuth residual exceeds 10.0 seconds, it is tagged as a 
possible outlier. Any chord distance with a residual greater that 1.0 meter is tagged as a possible outlier. 

Next, the default observation standard deviations are shown. A value of zero indicates no default was set. Also shown are 
A priori scalers to be applied to linear observations. In this example, the scalers are set to 1.0, so in effect, no scaling is 
applied. Scalers can be used to remove any systematic scale problems that are known before adjustment.

Finally, all adjusted observations are displayed mark-to-mark, corrected for instrument heights, target heights, refraction, 
and deflections of the vertical, where appropriate. For each observation, its residual, residual standard deviation, 
standardized residual, residual/apriori standard deviation ratios, and observation redundancy are displayed.

Adjusted Observations (Mark To Mark)

Standardized Residual Rejection Constant ( Tau Stat )    = 3.21273
Residual / A Priori Stan Dev Rejection Constant          = 5.00000
Residual Rejection Constants For Each Observation Type
  Azimuth                                                = 10.000
  Hor Ang                                                = 10.000
  Zenith                                                 = 10.000
  Chord                                                  = 1.00000
  Delta X                                                = 1.00000
  Delta Y                                                = 1.00000
  Delta Z                                                = 1.00000
  Hgt Diff                                               = 1.00000

Obs Type    Num Obs    Default SD      Scaler

Azimuth         2       0.000
Hor Ang        14       0.000
Zenith         13       0.000
Chord          13       0.00000        1.000000000
Delta X         6       0.00000        1.000000000
Delta Y         6       0.00000        1.000000000
Delta Z         6       0.00000        1.000000000
Hgt Diff        4       0.00000        1.000000000

Stations             Observations                SD      Resid     Stan Res
                                                 SD      Resid SD  Resid/SD
AT  BENTLY           Azimuth   149-49-17.000     1.0000    1.1157    1.4600    
                     Corrected 149-49-18.669     1.0000
TO  5010             Adjusted  149-49-19.784     0.3745    0.7642    1.1157 
                                                 Redundancy          0.81

AT  5010             Hor Ang   148-48-43.000     1.7000    0.5201    0.4742    
BS  TIN CUP          Corrected 148-48-43.008     1.7000
TO  BEND             Adjusted  148-48-43.529     0.9434    1.0968    0.3059 
                                                 Redundancy          0.57
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AT  5010             Delta Z      21638.55000    0.4243    0.2238    0.6617    
TO  TIN CUP          Adjusted     21638.77379    0.1264    0.3382    0.5275 
                                                 Redundancy          0.88

AT  BEND             Hgt Diff       399.63000    0.0300    0.0004    0.1188    
TO  BENTLY           Adjusted       399.63043    0.0253    0.0036    0.0143 
                                                 Redundancy          0.02

1 - Exceeds Standardized Residual Rejection Constant
2 - Exceeds Residual / A Priori SD Rejection Constant
3 - Exceeds Observation Residual Rejection Constant

The next section shows information pertaining to GPS observations only. For each baseline, the residuals are shown in a 
Local North, East, Up horizon. This facilitates the identification of possible instrument/antenna centering errors (shown as 
Delta North and Delta East) and instrument/antenna height measurement errors (shown as Delta Up). Field observations 
are the original measured values, not the adjusted values.

GPS Local NEU Residuals

Stations             Field Observations         Local NEU Residual

AT  5010             Delta X      28524.00000   Delta N     0.23906
TO  TIN CUP          Delta Y      17563.70000   Delta E    -0.35724
                     Delta Z      21638.55000   Delta Up    0.06219

AT  BENTLY           Delta X      21472.25000   Delta N    -0.36388
TO  5010             Delta Y     -23765.60000   Delta E     0.15805
                     Delta Z     -28365.25000   Delta Up   -0.01587

The next section lists the adjusted 2D geodetic inverses between all connected station pairs. The geodesic is the shortest 
distance between the two stations on the ellipsoidal surface. The geo chord is the chord distance between the two stations.

Adjusted 2D Geodetic Inverses

AT               TO
Fwd Az           Bwd Az          Geodesic        Geo Chrd

5010             BEND
194-34-57.705     14-28-38.076    57344.2628     57344.0687

5010             BENTLY
329-58-54.215    149-49-19.725    42777.0325     42776.9520

The next section lists the adjusted 3D ECEF delta XYZ inverses between all connected station pairs. To determine the 
backward vector, simply reverse the sign of each vector component.

Adjusted 3D GPS XYZ Inverses

AT               TO
Delta X          Delta Y        Delta Z

5010             BEND
 -14338.0811      -34682.4394     -43371.3815
5010             BENTLY
 -21472.4082       23765.8199      28365.5402
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The next section lists the adjusted 3D Astro geodetic inverses between all connected station pairs.

Adjusted 3D Astro Geodetic Inverses (connected stations)

AT               TO
Fwd Az           Bwd Az           Fwd Zen         Bwd Zen         Chord

5010             BEND
194-34-58.498     14-28-37.235    90-51-25.271    89-39-36.656     57354.4149

5010             BENTLY
329-58-55.090    149-49-18.116    90-27-38.418    89-55-32.170     42784.1371

The next section lists the distance errors between all connected station pairs. The distance errors have been scaled to the 
95% confidence interval (approximately 2 sigma) by the 1D expansion factor. PPM is computed as (standard deviation / 
distance * 1,000,000).

Distance Errors

Confidence Level  0.950
Expansion  1D     1.959

AT               TO               Distance    Stan Dev    PPM      Ratio

5010             BEND              57354.415   0.3066    5.3452    1:187083

5010             BENTLY            42784.137   0.1552    3.6280    1:275638

The next two sections list the station and relative error ellipses for the network. The semi-major and semi-minor axes have 
been scaled to the 95% confidence region (approximately 2 sigma) by the 2D expansion factor. The height error has been 
scaled to the 95% confidence interval by the 1D expansion factor. PPM is computed as (semi-major axis / chord distance * 
1,000,000). 

Station 2D Error Ellipses

Confidence Level  0.950
Expansion  1D     1.959
Expansion  2D     2.448

AT                  Major      Minor      Azimuth      Height

5010                0.2727     0.2350        12.8      0.1010

BEND                0.5714     0.4789       119.0      0.0877

Connected Station 2D Error Ellipses
Confidence Level  0.950
Expansion  1D     Chi Square  1.959
Expansion  2D     Chi Square  2.448   (1st row)
Expansion  2D     'F'         2.525   (2nd row)
AT               TO
Semi-Major Semi-Minor Azimuth     Height      Chord       PPM      Ratio
5010             BEND
0.5072     0.3680     122.3       0.1035   57354.4149    8.8427   1:113088
0.5230     0.3795     122.3       0.1035   57354.4149    9.1195   1:109655

The next section lists the station and relative error ellipsoids for the network. The azimuth and zenith angles describe the 
orientation of the error ellipsoid relative to North and Up, respectively. The semi-major, semi-medium and semi-minor axes 
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have been scaled to the 95% confidence region (approximately 2 sigma) by the 3D expansion factor. PPM is computed as 
(semi-major axis / chord distance * 1,000,000).     

Station 3D Error Ellipsoids

Confidence Level  0.950
Expansion  3D     2.795

AT                  Major      Medium      Minor

5010                0.3115     0.2684      0.1439
Azimuth              12.8      102.8        17.8
Zenith               88.7       89.9         1.3

BEND                0.6524     0.5469      0.1251
Azimuth             119.0       29.0        25.2
Zenith               90.0       89.8         0.2

Connected Station 3D Error Ellipsoids

Confidence Level  0.950
Expansion  3D     2.795

AT               TO
           Major      Medium      Minor      Chord       PPM

5010             BEND           
           0.5791     0.4202      0.1477   57354.4149    10.0977
Azimuth     122.3      32.3        71.3                   1:99032
Zenith       90.1      90.1         0.1

5010             BENTLY         
           0.2286     0.2098      0.1314   42784.1371     5.3425
Azimuth       8.4      98.4        11.3                   1:187180
Zenith       88.4      89.9         1.6

Adjust the MIXED.TXT network using orthometric height as the vertical control instead of ellipsoidal height. To do this, from 
the Options menu, select Global Settings and change the 3D Geodetic Height option to Orthometric Height. 
COLUMBUS will then use the Ortho Hgt field for any station held fixed in 1D or 3D. For this network, the orthometric height 
of 1033.07590 meters for Station MACK would be used rather than the ellipsoidal height of 1000.00000 meters.

Try adjusting the remaining vertical, geodetic, State Plane, UTM, and Local Horizon networks and compare your results 
with the applicable *.RPT file. The abbreviated instructions for solving each network are described within each *.TXT 
sample file.
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A Word About Approximate Coordinates

2D and 3D adjustments are iterative processes requiring an initial starting solution. The initial starting solution is given by 
the initial approximate coordinates for the unknown stations. Most of the time, COLUMBUS can compute these 
approximate coordinates using the selected control stations and the measured observations. Occasionally, however, 
COLUMBUS is unable to compute approximate coordinates for one or more stations. In the event this occurs, you must 
provide the approximate coordinate for these stations (which usually can be scaled from a map). For additional information 
regarding approximate coordinates, please visit the Quick Tips section of our Web site (www.bestfit.com).

User-supplied approximate coordinates can be entered directly from one of the applicable Data - Stations dialog, or they 
can be entered within the ASCII (Text) input project file.

When creating a network containing only terrestrial observations (no GPS), you must provide network orientation 
by including either an azimuth, bearing, local NEU vector OR a second 2D or 3D control station.
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GPS And Conventional File Format Support

GPS baselines (vectors) can be integrated into your ongoing geodetic projects. COLUMBUS currently supports Ashtech, 
Leica, Topcon, and Trimble post-processing files. Other receiver manufacturers generally have the ability to create the 
above receiver file types or they can create NGS Bluebook files, which we also support. We also support formats that are 
often used for conventional observations, including: TDS rw5 and raw, Topcon XML, and Nikon raw.

For each supported format, the process for loading the data into a COLUMBUS is essentially the same: Convert the 
supported file format to the COLUMBUS file format, then load the resulting file into COLUMBUS. Some of these conversion 
tools are built directly into COLUMBUS, while others are implemented as stand-alone tools. New support for additional 3’rd 
party formats are being developed as stand-alone conversion tools. We have adopted this approach so that we can 
maintain these tools without changing the COLUMBUS software itself. It also allows us greater flexibility in making new 
conversion tools available without scheduling them into a future release of COLUMBUS. Downloads of the current stand-
alone tools can be found at www.bestfit.com/file_conversion.shtml

Figure 7: GPS Vector Extraction Dialog Box

3’rd party data extraction can be completed in one COLUMBUS session or over the life of the project. With our new Include 
File support, you can create one master.txt file and include hundreds of smaller files, each possibly representing a day of 
field collection. At any time, you can load the master.txt file and the included files will automatically be loaded. You can 
then verify loop closures or perform ongoing adjustments.

GPS file formats supported from the File - Convert 3rd Party files - GPS Receiver Files menu are described below. All 
other supported formats are implemented as stand-alone conversion tools (mentioned above).

Ashtech GPS Receivers
Ashtech ‘O’ bimary files contain GPS vectors. We support this file type directly. 

Leica GPS Receivers
Leica uses an ASCII file format created within their SKI software system.
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Sokkia GPS Receivers
Sokkia supports the creation of many different file formats. You can even create a GeoLab-compatible file that we 
can convert to the COLUMBUS format.

Topcon-GeoComp GPS Receivers
These receivers create a text file containing one baseline solution per file. Topcon also allows you to create 
Ashtech ‘O’ files and Topcon XML files, which we directly support.

Trimble GPS Receivers
Trimble baseline files come in a variety of forms, depending on the type of GPS survey performed. COLUMBUS 
supports ASCII and binary formats. 
The supported ASCII format is for the single baseline 640 processor. These include *.FIX, *.FLT and *.TRP files. 
The binary *.SSF format is supported from output from the multi-baseline processor. These files contain float, triple, 
fixed or fast-static solutions. 
The *.SSK binary file is created from the multi-baseline processor from data collected during kinematic and 
pseudostatic surveys. These file are also supported.
Wave processor files for rapid static surveys (may have SSK or SSF file extension).
Trimble Geomatics Office text file output files. These are processed within COLUMBUS by selecting from the File 
menu, the Convert 3rd Party Files command, and then selecting Trimble Geo Office (*.ASC Files).

To extract baseline data from any of the above receiver manufacturer files, the steps are essentially the same. 
They are summarized below:

1. Determine the receiver manufacturer file type to be processed. Some vendor files contain only one baseline per 
file. Others contain several baselines within each file.

2. From the File menu, select Convert 3rd Party Files and select the file type to process.
3. Next, decide if the variance - covariance matrix for each baseline should be scaled. Most of the time, you will use 

the default scaler of 1.0 (i.e., in effect, no scale change). You can also scale individual baselines, groups of 
baselines, or all baselines by imbedding the $S_XYZ_COV keyword throughout the resulting ASCII (Text) file. See 
Appendix A for more information on the $S_XYZ_COV keyword.
To scale all the current baseline variance - covariance matrices, type the scaler value in the Covariance Scaler 
edit box. As each baseline is extracted, the variance - covariance matrix for that baseline will be multiplied by the 
scale factor, then written to the resulting ASCII (Text) file.

4. To begin the extraction process, click the Start button. You will be prompted to select one or more GPS receiver 
files. To select a range of files, select the first file in the range and then, holding the Shift key down, select the last 
file in the range. To select multiple files, hold the CTRL key down and click on each file individually. All selected 
files will be highlighted. 

5. After making your file selection, click the Open button. COLUMBUS will prompt you for the name of a COLUMBUS 
ASCII (Text) data file in which to write the extracted GPS baseline data. 

6. After entering a file name, click the Save button and COLUMBUS will begin processing your files. As each baseline 
is extracted, the Baseline Counter is incremented by one.

The resulting ASCII (Text) data file can be opened or appended into COLUMBUS by selecting from the File menu either 
Open or Append. You can either edit your control stations from within COLUMBUS (after opening the data file) or within 
the ASCII (Text) data file itself. Within the ASCII (Text) data file, each station is represented in geodetic form. They can be 
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identified by the $GEO or $GEO_COMPACT code. Latitudes are positive in the Northern Hemisphere and negative in the 
Southern Hemisphere. Longitudes are positive in the Eastern Hemisphere and negative in the Western Hemisphere.

When editing stations within the ASCII (Text) data file, it is only necessary to edit the first instance of the station, i.e., the 
first time the station is defined in the file by the $GEO code. When the data file is opened, each additional instance, if 
applicable, is ignored.

Note: 

When you open the ASCII (Text) data file, it will be associated with whichever datum is active. Therefore, be sure to select 
the appropriate datum prior to opening your ASCII (Text) files by selecting Datums from the Options menu and selecting 
the desired datum. If your datum is not internally supported, you can add a new datum.

To add a new datum: 

1. Open a new empty project by selecting New from the File menu.
2. From the Data menu, select Datums. Click on the Add Datum button and enter the datum name, semi-major axis 

and 1/f coefficient.
3. Click the Keep and Exit button to close the dialog and keep the changes.
4. From the Options menu, select Datums and select the new datum to be active.
5. The datum entered is now configured into COLUMBUS and is active. Close the current empty project.



Copyright 1996-2009 Best-Fit Computing, Inc. Demo Doc-33

Solve All Combinations For Constrained Adjustments

COLUMBUS supports an advanced technique to automate the search for the best-fit network adjustment solution. This 
technique, available for 1D, 2D and 3D networks, is accessed through the Adjustment Combinations Tool (from the 
Network menu, select Adjustment (Fixed – All Cases). It is based on combinatorial theory, which is applicable to many 
real-world problems.

Combinatorial Theory

Suppose you own a small surveying firm and have just received a GPS control survey contract. To complete this survey on 
time, you have estimated at least three experienced GPS surveyors must be dedicated to the project. Within your small 
company, there are five people qualified from which to choose (Tom, Mary, Dave, Alice and Andy). At the moment, all five 
are free to work on this project. The question, then, is which people should be put on the project? How many combinations 
of solutions are possible?

You could decide to put only three on the project. Or you might add a fourth or fifth to finish sooner.

Tom, Mary, Dave
Tom, Mary, Alice
Tom, Mary, Andy
Tom, Mary, Dave, Alice
Tom, Mary, Dave, Andy
Tom, Mary, Dave, Alice, Andy

As you might expect, the total number of possible combinations can grow very large. In fact, the actual number of 
combinations is given by applying the formula below.

N!
-----------------
K! * (N - K)!

where:

! = factorial
N = total number of qualified people available (in this case, five)
K = number of qualified people for any given solution

For this example, the formula needs to be applied three times: once for K = 3, once for K = 4 and once for K = 5. The 
results from each are then added together.

The answer to this example is: 10 + 5 + 1 = 16

Note:
5! = 5 * 4 * 3 * 2 * 1
4! = 4 * 3 * 2 * 1
3! = 3 * 2 * 1
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How Does This Apply To Network Adjustment?

For a network adjustment the same type of process can be applied, but instead of different people, we have several 
different control stations. Each control station is uniquely identified by its known coordinates.

The Adjustment Combinations Tool can be used when you are ready to perform a constrained adjustment. Before using 
this tool, you should have performed repeated free adjustments and removed any possible bad observations. 

If you have several control stations tied to your network, several possible combinations of control station scenarios exist. 
You could use all the control you have, or you might decide to use a subset of your total available control. Using other 
adjustment software systems you would perform several constrained adjustments, altering which stations are set up to be 
fixed for each adjustment. After finding the most favorable results, you would perform a final adjustment and be done. 

The manual process described above would require many hours of user intervention as you changed the configuration of 
control for each adjustment combination. Also, you might leave one of the possible combinations out, never knowing if it 
would have been the best solution. With the Adjustment Combinations Tool, COLUMBUS performs these iterative steps 
for you quickly, easily, and without leaving any possible solution untested! You simply set up the processing parameters, 
begin processing, then take a coffee break. Meanwhile, your computer continues to work on your behalf.

Example: 

You have a 3D geodetic network consisting of 17 stations (use BIGBASIN.TXT) and over one hundred observations. You 
have completed the free adjustment process and have removed all poor quality observations. Of the 17 stations in your 
network, you have known 3D geodetic coordinates for four of the stations and known 1D height for three additional stations. 
Set the 1D fixed stations 15, 103, 22. Set the 3D fixed stations CARBON, CHANEY, FORT LEWIS, and LA PLATA.

Within COLUMBUS, you would select these stations to be fixed in 1D and 3D, respectively. Select all observations to be in 
the network (Network - Observations menu). From the Network menu, select Adjustment (Fixed - All Cases) to bring 
up the adjustment search dialog as shown below. Here is where you specify the combinations of control configurations that 
are desirable in any final solution. This is accomplished by setting up the minimum and maximum number of control station 
types you want to have in each acceptable configuration.
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For any constrained 3D geodetic network, you need a minimum of three fixed combination parameters (two fixed 
parameters are required for 1D or 2D networks). Stations fixed in 1D or 2D count as one parameter. Stations fixed in 3D 
count as two parameters - since they have both a 1D and 2D component. This parameter concept is only applicable to 
solving all combinations. A constrained 3D geodetic network would require (at a minimum) any of the following:

One 1D fixed station + one 3D fixed station
One 2D fixed station + one 3D fixed station
Two 1D fixed stations + one 2D fixed station
Two 2D fixed stations + one 1D fixed station
Two 3D fixed stations

Note: Three or more stations fixed in only 2D or only 1D will not work, since you need at least 3D worth of control for a 3D 
constrained adjustment.

By selecting the minimum and maximum number of control stations you are willing to accept in any possible solution, the 
range of possible solutions can increase or decrease. 

For this example, we have decided that each solution must have at least one station fixed in 1D and one station fixed in 3D. 
You would declare this by setting the Minimum boxes for 1D and 3D stations to '1'. Additionally, we have decided we want 
a maximum of two 1D stations in any given solution. You would declare this by setting the Maximum box for 1D stations to 
'2'. Finally, for any given solution, we want no more than two stations to be fixed in 2D. You would declare this by setting the 
Maximum box for 2D stations to '2'.

For the settings above, each combination solved by COLUMBUS will have:

At least one station fixed in 1D
At least one station fixed in 3D
No more than two stations fixed in 1D
No more than two stations fixed in 2D
No more than four stations fixed in 3D
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Click on the Compute Combinations button to calculate the total number of combinations that will be solved. For this 
example, 700 solutions fit the criteria! Each one of these combinations would satisfy the constraints defined above.

As you can see, there are many possible solutions even with as few control stations as described above. To perform this 
task manually would be error prone and very time-consuming.

Click on the Start button and watch COLUMBUS do the work. After the processing has completed, open the Results - 
Best Constrained Combos view to see the top 500 solutions. To view the stations that were held fixed (in 1D, 2D, or 3D) 
for any given solution, higlight the solution, then click on the View Fixed Station Details toolbar button. You can also use 
the File - Print Preview command or generate a report to see more detailed information about each solution.

How Solutions Are Ranked

As COLUMBUS processes each new combination, it keeps track of the top 500 solutions based on two independent tests: 
the A Posterior Variance Factor Test and the Residual Distribution Test. When processing is complete, these solutions 
can be displayed and printed. You can then pick which of these solutions to use as your final constrained adjustment. Or 
you might take a closer look at the top 10 solutions by solving them individually and looking at several other statistical 
indicators presented by COLUMBUS after the traditional network adjustment process.

The A Posteriori Variance Factor ranking is always performed. The closer the A Posteriori Variance Factor is to 1.0, the 
better the ranking for a given solution. This test does not require a final inverse on each solution - resulting in faster 
processing times for larger networks.

The Residual Distribution Test is optional. It will give you a numerical indicator as to how evenly the Standardized Residuals 
(for all observations) are distributed about their mean. Since this test requires additional statistical information found within 
the final inverse for each solution, it will lengthen processing times for large networks when enabled.

These are just two tests used by COLUMBUS to help you narrow down the 700 possible solutions to about 10-20 solutions. 
You can then examine individual solutions (from the top 20) by performing a separate network adjustment based on each 
scenario.
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Why Not Just Use All Known Control?

The answer depends on the quality of the control in your area. Some control points may be more reliable than others, 
based on how they were established. Some control points may have been disturbed since they were originally surveyed. 
This could be a result of geological movement, vandalism or even wildlife. Simple instrument centering/height 
measurement errors could also influence the observed quality of any given control station. You may never know if the 
control point has these problems, because your first inclination may be to suspect your own observations.

By solving all possible combinations, you have the best opportunity to eliminate control that may be introducing 
significant errors into your project.
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Contacting Best-Fit Computing

We hope you’ve enjoyed working with our geodetic network adjustment software. If you have any questions, comments or 
would like to order COLUMBUS, please contact us at:

Best-Fit Computing, Inc.
17490 NW Woodmere Court

Beaverton, Oregon 97006 USA

Phone (503) 531-8819
  Fax  (503) 214-5406

info@bestfit.com

Also, please visit our Web site at http://www.bestfit.com/.
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